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Using the DNI_Demo spreadsheet

John Wood v1.1 Mar 2012

Introduction
The DNI_Demo spreadsheet contains a suite of functions that can be used to calculate the position 
of the sun, and hence Direct Normal Irradiance (DNI) or Direct Irradiance on any arbitrary surface. 
The spreadsheet gives examples of these calculations. 

Installation
This example spreadsheet has been tested in Excel 2003 & Excel 2010. 

Open the spreadsheet and click on ‘Enable 
Macros’ or ‘Enable content’ if you are given this 
choice. The speadsheet will load and show two 
sample worksheets along with a Help sheet. 

General principles

The different variations of Direct beam measurement
The SPN1 and BF5 measure Total (Global) 
and Diffuse Irradiance, usually on a 
horizontal plane. The Direct Irradiance on 
a horizontal surface is easily calculated as 
Total - Diffuse from a horizontal SPN1. 

Direct Normal Irradiance (DNI) is the 
Direct radiation received from the sun by 
a sensor (or surface) that is directly facing 
the sun, and tracks the sun throughout 
the day. 

Direct Irradiance on a sloping surface is 
the Direct radiation received from the 
sun by a sensor (or surface) which is not 
horizontal, but has a fixed orientation (eg a solar panel on a sloping roof). 

Excel 2010 Macro security warning 
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The sample spreadsheets
The DNI_Demo spreadsheet calculates estimates of DNI and Direct Irradiance on a sloping surface, 
from measurements made by a horizontal SPN1 or BF5 sensor. More detailed reference material on 
all the spreadsheet functions is given later in the Reference sections of this document 

The DNI sheet
This sheet shows a basic calculation of Direct Normal Irradiance from a BF5 or SPN1 dataset. 

The header at the top in blue holds values relating to your site, particularly Latitude, Longitude & 
Timezone.  The example shown is a site in China.  

The most likely cause of error in the calculations is incorrect entry of site and timezone details. There 
are several ways to check that these values are entered correctly:  the conventional latitude & 
longitude display, the Timezone expected from your longitude, and the times of sunrise & sunset. 

To assist in setting up the spreadsheet functions, the Latitude, 
Longitude & Timezone cells are named as such in the blue 
header area - (you can see the names in the dropdown box at 
the top left of the worksheet when you click in one of these 
cells). You will need to create cells with these names if you set 
up your own spreadsheets. 

The DNID_Localtime() function is used to calculate the DNI 
from Local time, Total and Diffuse. The function also needs to 
know your Latitude, Longitude & Timezone, and these values 
are automatically taken from the named cells in the header. 
This simplifies setting up the calculation. 

To use this sheet for your own data, delete the sample dataset, but leave the blue headers 
there. Paste in your own data, and set your site values correctly. In your DNI column, use the 

The entered Latitude & Longitude are displayed in degrees, 
minutes & seconds, North/South or East/West. 

Enter your Timezone in hours ahead 
of or behind GMT. Your expected 
Timezone, based on your longitude, 
should be similar to this. 

By entering a date, the Sunrise & Sunset will be shown 
for that date, in your local time. Check that these values 
agree with published values, and with the beginning & 
end of daylight as shown in your dataset. 
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formula =DNID_Localtime(Localtime, Total, Diffuse) and point the  three arguments to 
the correct values. Copy the function down to the end of the dataset. 

Note: Recalculation. Excel does not automatically recalculate the XXX_Localtime() functions if 
the Latitude, Longitude or Timezone values are changed. There is also a bug in the Excel graphing, 
which means the graphs do not always update if the data changes. The      recalculate     button on 
the sheet will force an update of all calculations and graphs, ensuring your spreadsheet is consistent. 

The Demo sheet
As well as the DNI calculation, this sheet shows a larger range of calculations, this time based on a 
UK dataset. There is also an extended header section, containing additional parameters. 

In columns D & E, the usage of the DNID() function is shown next to the DNID_Localtime() 
function. The results are the same, but DNID_Localtime() has simplified arguments. However, it 
will only work with the blue header block present. 

The header block includes two additional 
sections. The Atmosphere section 
contains an atmospheric extinction 
coefficient, which is used to calculate the 
expected DNI for a clear sky. This 
extinction coefficient is loosely equivalent to the Aerosol Optical Depths measured by atmospheric 
scientists, and is typically in the range 0.1 for very clean air, to 0.4 for polluted air. 

The Sloping surface section is used for calculations of Direct 
irradiance on a sloping surface such as a solar panel. The 
Surface Azimuth value is the compass point that the surface 
slopes towards. 90° represents a surface facing East, 180° facing 
South, and 270° facing West. The Surface Zenith value is the 
angle the surface is tilted away from horizontal. 0° represents a 
horizontal surface, and 90° a vertical surface. In this example, it 
is a surface inclined at 53° from horizontal, facing due South. 

In column F, the DirectMaxD_Localtime() function 
calculates the expected DNI for clear-sky conditions, based on 
the atmospheric extinction coefficient entered in the header 
section.  You can adjust the extinction coefficient to match your 
actual readings on a clear day. 

Column G calculates the Direct irradiance on a sloping surface, 
as defined in the header. 

Columns H I & J show calculations of the solar Zenith angle, 
Altitude (= 90° - Zenith), and Azimuth angle. 
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Using these worksheets for your own data
The simplest way of using this spreadsheet is to delete the sample data and copy in your own data to 
the appropriate worksheet. Set up any graphs or other calculations you need, then save the 
spreadsheet with another name. 

If you need to create additional worksheets within the DNI_Demo workbook, then right-click on the 
worksheet tab and select the ‘Move or Copy’ command. This will create a complete new worksheet 
that includes all the required named cells and functions. Just copying and pasting a selection of cells 
will not work so well. 

Sheet protection
The two sample data worksheets are protected, which helps to prevent accidental modification of 
the blue header blocks. You can modify the rest of the worksheet as you wish, but there are some 
minor restrictions, eg in changing the layout of graphs. If these prevent you from doing what you 
need, you can remove the protection from the worksheet: 

In Excel 2010:  File -> Info -> Permissions -> Unprotect 

In Excel 2003:  Tools -> Protection -> Unprotect sheet. 

This will give you full control over the worksheet, but be careful not to change the blue header block. 
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Function Reference

Times Dates
Most functions require the Date & Time to calculate solar position. Times & Dates use the Excel Date 
format. If you can format your values in Excel as date or time, these values will be usable.  

Note: The Date format is based on a count of days from the start of 1900 (there is an alternative 1904 setting 
in Excel, but these functions require the 1900 setting). The number increments by 1 every day, with the 
fractional part of the number starting at .0 at midnight. 

Most of the functions in this spreadsheet require the date and time in Universal time (GMT or UTC), 
but your data will probably be in your local time zone. You will need to know your time zone to 
convert between the two. This is entered in hours ahead or behind GMT in these spreadsheets, so 
must be divided by 24 to get the correct scaling for Date format. One check on your time zone is to 
look in the Windows Time Zone Settings, which will give the time zone for your current PC location. 
Be aware that you may also have to account for any Daylight Saving Time adjustment. 

To get Universal time from Local time:  Universal = Localtime - Timezone / 24 

To get Local time from Universal time:  Localtime = Universal + Timezone / 24 

There is a subset of functions which take inputs in Localtime, and relies on named cells in the 
worksheet to calculate Universal time internally. These are all named XXX_Localtime. 

Location
Your site location is another key input to many of the functions. Latitudes are entered in decimal 
degrees, with positive values for North, negative values for South. Longitudes are entered in decimal 
degrees, with positive values for East, negative values for West. 

Finding Functions
The complete set of functions available can be seen 
from the Formulas, Insert Function menu (Insert 
Function in XL2003), or by clicking on 
the button at the top of the 
worksheet, and selecting the Solar & DNI category.  

Note: All functions ending in _Localtime require 
the named values in the blue header block to work 
properly. Other functions can be used 
independently. 
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Function Definitions

DateTimeSerial(JulianDate) 

Returns an Excel date in Universal time (GMT). 

JulianDate is a number used by astronomers to represent time, and counts the number of days since 
midday, January 1, 4713 BC. Integer parts of the number represent days, fractional parts represent 
time of day. The fractional part is zero at midday. 

Julian(DateSerial) 

Returns the Julian date 

DateSerial is an Excel date in Universal time (GMT). This is represented by the number of days since 
the start of the year 1900. Integer parts of the Date represent days, and fractional parts represent 
time. The fractional part is zero at midnight. 

DeclinationD(DateSerial) 

Returns the solar declination in degrees. This represents the angle of the sun North or South of the 
plane of the equator, and varies between 23.5° at the summer solstice to -23.5° at the winter 
solstice. 

DateSerial is an Excel date in Universal time (GMT). 

RightAscensionD(DateSerial) 

Returns the solar Right Ascension in degrees. This represents the angle of the sun around the plane 
of the equator, relative to the fixed stars. 

DateSerial is an Excel date in Universal time (GMT). 

NormSolarDist(DateSerial) 

Returns the normalised solar distance, i.e. the Earth - Sun distance in astronomical units. This is used 
to calculate the extra-terrestrial solar radiation (ET) above the atmosphere. 

ET = 1370W.m-2 / NormSolarDist()^2 

DateSerial is an Excel date in Universal time (GMT). 

SiderealD(DateSerial, LongitudeD) 

Returns the local sidereal time for a given longitude, in the range 0 - 1. 
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DateSerial is an Excel date in Universal time (GMT). 

LongitudeD is the site longitude in degrees, positive values East, negative values West. 

UniversalD(DateSerial, LST, LongitudeD) 

Returns the Universal time (GMT) for a given sidereal time & longitude. 

DateSerial is an Excel date in Universal time (GMT). Any fractional part is ignored. 

LST is the local sidereal time, in the range 0 - 1. 

LongitudeD is the site longitude in degrees. 

EquationOfTime(DateSerial) 

Returns the difference between Universal time 
and solar time on the Greenwich meridian. This is 
given in fractions of a day.  

Because the Earth’s orbit is elliptical, the solar 
time (time as given by a sundial) moves up to 16 
minutes ahead or behind of clock time throughout 
the year. 

DateSerial is an Excel date in Universal time (GMT) 

ZenithD(DateSerial, LatitudeD, LongitudeD) 

Returns the zenith angle of the sun in degrees. 

DateSerial is an Excel date in Universal time (GMT). 

LatitudeD is the site latitude in degrees, positive values 
North, negative values South. 

LongitudeD is the site longitude in degrees, positive values 
East, negative values West. 

AltitudeD(DateSerial, LatitudeD, LongitudeD) 

Returns the altitude angle of the sun in degrees. Altitude = 90° - Zenith. 

DateSerial is an Excel date in Universal time (GMT). 
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LatitudeD is the site latitude in degrees, positive values North, negative values South. 

LongitudeD is the site longitude in degrees, positive values East, negative values West. 

AzimuthD(DateSerial, LatitudeD, LongitudeD) 

Returns the azimuth angle of the sun in degrees.  

DateSerial is an Excel date in Universal time (GMT). 

LatitudeD is the site latitude in degrees, positive values North, negative values South. 

LongitudeD is the site longitude in degrees, positive values East, negative values West. 

SunriseD(DateSerial, LatitudeD, LongitudeD) 

Returns the time of sunrise in Universal time (GMT) on the given date for the site. Add Timezone 
(hrs) / 24 to give local sunrise time. If the sun never sets (eg Arctic summer) then SunriseD returns 
midnight for the standard timezone of the latitude. If the sun never rises (eg Arctic winter) then 
SunRiseD returns midday for the standard timezone of the latitude. 

DateSerial is an Excel date in Universal time (GMT). Any fractional part is ignored. 

LatitudeD is the site latitude in degrees, positive values North, negative values South. 

LongitudeD is the site longitude in degrees, positive values East, negative values West. 

SunsetD(DateSerial, LatitudeD, LongitudeD) 

Returns the time of sunset in Universal time (GMT) on the given date for the site. Add Timezone 
(hrs) / 24 to give local sunset time. If the sun never sets (eg Arctic summer) then SunriseD returns 
midnight for the standard timezone of the latitude. If the sun never rises (eg Arctic winter) then 
SunRiseD returns midday for the standard timezone of the latitude. 

DateSerial is an Excel date in Universal time (GMT). Any fractional part is ignored. 

LatitudeD is the site latitude in degrees, positive values North, negative values South. 

LongitudeD is the site longitude in degrees, positive values East, negative values West. 

DNID(DateSerial, LatitudeD, LongitudeD, Total, Diffuse) 

Returns the Direct Normal Irradiance for the time and site, calculated from values of Total & Diffuse 
horizontal irradiance. The units of DNI are the same as those used for Total & Diffuse. The DNI is 
calculated as DNI = (Total - Diffuse) / cos(Zenith). In order to reduce the large spikes that this 
calculation typically creates when the sun is near the horizon, the 1/cos(Zenith) scaling factor is 
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progressively reduced to zero for zenith angles between 88° & 90°. DNID always returns zero for 
zenith angles > 90° (ie sun below the horizon), or if the Diffuse value is greater than the Total value. 

DateSerial is an Excel date in Universal time (GMT).  

LatitudeD is the site latitude in degrees, positive values North, negative values South. 

LongitudeD is the site longitude in degrees, positive values East, negative values West. 

Total & Diffuse are horizontal irradiance values, eg from SPN1 or BF5. 

DNID_Localtime(DateSerial, Total, Diffuse) 

A simplified form of the DNID function. This requires cells named Latitude, Longitude and Timezone 
to be present on the same worksheet as this function is used, containing the Latitude, Longitude 
(degrees) and Timezone (Hrs) values for the site. 

DateSerial is an Excel date in Local time.  

Total & Diffuse are horizontal irradiance values, eg from SPN1 or BF5. 

DirectMaxD(DateSerial, LatitudeD, LongitudeD, Extinction) 

Returns the expected clear-sky DNI in W.m-2 for the time and site, based on the given extinction 
coefficient. This uses the following calculation: 

AirMass = 1/Cos(Zenith) 

ExtRad = 1370W.m-2 * NormSolarDist()^2 

DirectMaxD = ExtRad * Exp(-Extinction * AirMass) 

DateSerial is an Excel date in Universal time (GMT).  

LatitudeD is the site latitude in degrees, positive values North, negative values South. 

LongitudeD is the site longitude in degrees, positive values East, negative values West. 

Extinction is similar to the Optical Depths used by atmospheric scientists, but integrated over the 
whole solar spectrum. Typical values range from 0.1 in clean air to 0.4 for more polluted 
atmospheres. 

DirectMaxD_Localtime(DateSerial) 

A simplified form of the DirectMaxD function. This requires cells named Latitude, Longitude, 
Timezone and Extinction to be present on the same worksheet as this function is used, containing 
the Latitude, Longitude (degrees), Timezone (Hrs) and Extinction (0 to 1) values for the site. 
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DateSerial is an Excel date in Local time.  

DirectSlopeD(DateSerial, LatitudeD, LongitudeD, Total, 
Diffuse, SurfaceAzimuthD, SurfaceZenithD) 

Returns the Direct Irradiance for the time and 
site, calculated from horizontal Total & Diffuse 
measurements, on a fixed sloping surface 
described by the SurfaceAzimuthD & 
SurfaceZenithD values. 

DateSerial is an Excel date in Universal time 
(GMT).  

LatitudeD is the site latitude in degrees, positive 
values North, negative values South. 

LongitudeD is the site longitude in degrees, positive values East, negative values West. 

Total & Diffuse are horizontal irradiance values, eg from SPN1 or BF5. 

SurfaceAzimuthD is the direction that the perpendicular to the surface is pointing, in degrees from 
North via East. 

SurfaceZenithD is the angle between the zenith (vertical) and the perpendicular to the surface, in 
degrees. This is the same as the angle between the plane of the surface and horizontal. 

DirectSlopeD_Localtime(DateSerial, Total, Diffuse) 

A simplified form of the DirectSlopeD function. This requires cells named Latitude, Longitude, 
Timezone, SurfAz and SurfZen to be present on the same worksheet as this function is used, 
containing the Latitude, Longitude (degrees), Timezone (Hrs) and surface orientation values for the 
site. 

DateSerial is an Excel date in Local time.  

Total & Diffuse are horizontal irradiance values, eg from SPN1 or BF5. 

OpticalDepthD(DateSerial, LatitudeD, LongitudeD, Total, 
Diffuse) 

Returns the Optical Depth (Extinction coefficient) calculated for the time and site, from Total & 
Diffuse measurements in W.m-2. 

DateSerial is an Excel date in Universal time (GMT).  

LatitudeD is the site latitude in degrees, positive values North, negative values South. 
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LongitudeD is the site longitude in degrees, positive values East, negative values West. 

Total & Diffuse are horizontal irradiance values in W.m-2, eg from SPN1 or BF5. 

Spreadsheet reference

Creating template
To make these functions easily available for many datasets, you can save the spreadsheet as a 
template. 

Delete any of the worksheets you do not need, and delete the sample data from the worksheets, 
leaving only the blue header block. 

In Excel 2003: File -> Save As and select Template(*.xlt) and save it in the Excel Templates folder. 

In Excel 2010: File -> Save As and select Excel Macro-Enabled Template (*.xltm) and save it in the 
Excel templates folder. 

The template will then be available every time you create a new spreadsheet using the File -> New -> 
My Templates command. 

Workbooks created this way will work on your computer, and other computers, as long as the 
Macros/Content is enabled when the spreadsheet is opened. 

Creating an add-in
The functions in this spreadsheet can be permanently installed in Excel by loading them as an add-in. 
This makes them permanently available to all your workbooks without having to load a template or 
modify the original file. However, Workbooks created using these add-in functions will not work 
correctly on other computers unless they also have the add-in loaded. 

In Excel 2010: Open DNI_Demo.xls. Then File -> Save As -> type Excel Add-In (*.xlam), and save in the 
AddIns folder. 

Then load the Add-In: File -> Options -> Add-Ins -> Manage: Excel Add-ins -> Go.  In the Add-Ins 
dialog, look for ‘Solar & DNI functions’ and make sure it is checked. If it is not on the list, then use 
the ‘Browse’ button and select the Add-In file you just saved. 

In Excel 2003: Open DNI_Demo.xls.  Then File -> Save As -> type Microsoft Office Excel Add-In (*.xla), 
and save in the AddIns folder. 

Then load the Add-In: Tools -> Add-Ins. In the Add-Ins dialog, look for ‘Solar & DNI functions’ and 
make sure it is checked. If it is not on the list, then use the ‘Browse’ button and select the Add-In file 
you just saved. 
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Comparison with previous versions
This spreadsheet is based on the previous SunCalc add-in. However, there are several differences 
between them: 

1. SunCalc was supplied only as an add-in, rather than as a demonstration spreadsheet. 

2. SunCalc functions all used radians to measure angles, whereas this version uses degrees. All 
equivalent functions in this version end with a 'D' to distinguish them from the SunCalc radian-based 
functions. 

3. Longitude in SunCalc was positive West, whereas this version uses positive East. 

4. This version contains Additional functions for DNI, DirectMax and OpticalDepth. 

This spreadsheet can coexist with the SunCalc add-in. 
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